Github Collection Degradation
Incident Report for Recorded Future
Resolved
Dear Client,
Thank you for your patience as we've continued to address full restoration of our Github collection processes. We are happy to relay that operations for Github collection have remained optimal with the updated solution, and we will mark this incident as resolved.

Please contact our support team at support@recordedfuture.com if you have any questions or concerns moving forward.

Regards,
Recorded Future Platform Operations
Posted Jun 20, 2023 - 10:14 EDT
Monitoring
Dear Client,
Thank you for your patience as we've continued to address full restoration of our Github collection processes. We are happy to relay that we have restored operations for Github collection back to normal volumes and data quality. This solution is live, and we are continuing to monitor.

We will formally close this incident after a sustained period of stable collection. Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted May 25, 2023 - 17:01 EDT
Update
Dear Client,
Thank you for your patience as we've continued to address restoration of our Github collection processes. Our data and product teams are continuing to work hard in finding a permanent solution to restore collection back to optimal levels, and we're hopeful in having a promising path forward within the next couple of weeks.

We will continue to keep this incident updated till we have a resolution. Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted May 09, 2023 - 10:28 EDT
Update
Dear Client,
Thank you for your patience as we've continued to address restoration of our Github collection processes. Unfortunately, attempts to fix thus far have not resulted in optimal performance, with the volume and quality of Github data ingested much lower than previous expectations.
Our data and product teams are continuing to work on avenues to improve performance pertaining to ingestion of this data, but we have no firm ETA at this time.

We will continue to keep this incident updated till we have a resolution. Please contact our support team at support@recordedfuture.com if you have any questions or concerns.
Posted Apr 28, 2023 - 12:00 EDT
Identified
Dear Client,

After much work on this, a significant portion of our Github collection has been restored and is functioning. There are some remaining issues that are still being worked on, so our Github collection remains in a degraded state but with significant improvements. The priority of collection has been altered so that best match for any curated term is prioritized.

We will continue to keep this incident updated till we have a resolution. Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted Apr 24, 2023 - 11:13 EDT
Investigating
Dear Client,

We have recently confirmed an ongoing service degradation with our Github collection, stemming from recent changes made by Github to their APIs. Our team is actively working to restore the collection, but we do not have a current timeline for full restoration.
After further investigation, we believe this incident started around April 11th, with particular impact to fast-moving terms (i.e. terms with many hits), with limited improvements seen thus far. We have also seen symptoms where old Github content appears to be ingested as new, when triggering alerts, which we believe to be related.

We will continue to keep this incident updated till we have a resolution. In addition, we will continue to monitor other code repositories for similar behavior. Please contact our support team at support@recordedfuture.com if you have any questions or concerns.
Posted Apr 19, 2023 - 09:01 EDT
This incident affected: Collection and Processing.