Performance issues with our Browser Extension

Incident Report for Recorded Future

Resolved

Dear Customer,

The performance issues with our Browser Extension have been resolved.

Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted Jun 26, 2025 - 09:35 EDT

Investigating

Dear Customer,

We are experiencing performance issues with our Browser Extension and our engineers are currently working to resolve this problem as quickly as possible.

Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted Jun 26, 2025 - 07:38 EDT
This incident affected: Browser Extension.