Degradation in Service for Advanced Query Builder and Viewing Alerts

Incident Report for Recorded Future

Resolved

Dear Recorded Future Customers,

We want to inform you that our Advanced Query Builder and viewing alerts in the Alerts Dashboard degraded performance have been resolved. System performance and response times are back to normal.

Please contact our support team at support@recordedfuture.com if you have any questions or concerns.

Regards,
Recorded Future Platform Operations
Posted Jun 23, 2025 - 23:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2025 - 22:40 EDT

Investigating

Dear Recorded Future Customers,

We want to inform you that our Advanced Query Builder and viewing alerts in the Alerts Dashboard are both currently experiencing degraded performance. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience. We will continue to provide updates as more information becomes available.
Posted Jun 23, 2025 - 19:36 EDT
This incident affected: User Interface and API.