Below is the root cause analysis for the Recorded Future service disruption:
Issue:
At approximately 9:10 UTC on June 4, 2025, the Recorded Future Portal, APIs and mobile application became unavailable.
Cause:
During a scheduled upgrade of an internal database, an error caused authentication requests to fail, resulting in the Recorded Future Portal, API and mobile application becoming unresponsive.
Remediation / Path Forward:
Our Platform Operations team recovered the database at approximately 9:45 UTC, and restarted impacted services. At approximately 10:52 UTC, the Recorded Future Portal, API and mobile application were confirmed to be responsive again. After a period of time to allow all relevant processes to operate normally, the incident was marked as fully resolved at 13:45 UTC.
Moving forward, database upgrades include a number of new safety features which should prevent this specific issue from recurring. In addition, automated database rollbacks will be implemented which should speed up recovery in the event of a future database failure.
Posted Jun 13, 2025 - 09:47 EDT
Resolved
Dear Customer,
We can now consider the service disruption with the Recorded Future platform to now be resolved, and a root cause analysis will be produced for this incident.
Please contact our support team at support@recordedfuture.com, or your Intelligence Services resource if you have any questions.
Regards, Recorded Future Platform Operations
Posted Jun 04, 2025 - 09:44 EDT
Update
Dear Customer,
We are currently experiencing a delay in our content collection and analysis processes.
This means that there is a delay between when content is published and when it is available in Recorded Future’s web application, API, and alerts. Other systems are running normally, historical data is still available, and we do not anticipate any data loss from this issue.
We will follow up when the system is back to normal, but please contact our support team at support@recordedfuture.com if you have any questions or concerns.
Regards, Recorded Future Platform Operations
Posted Jun 04, 2025 - 07:03 EDT
Monitoring
Dear Customer,
The Recorded Future team has resolved the recent system issue affecting the Recorded Future application portal, mobile application, and API, as described in our recent system issue alert email.
We understand the impact that a system disruption may have on your business. We have identified the underlying cause of this problem and are currently working on a solution to prevent it from occurring again.
You can contact our support team at support@recordedfuture.com to discuss this issue or any other questions you may have regarding our products. We are always here to help.
Regards, Recorded Future Platform Operations
Posted Jun 04, 2025 - 06:57 EDT
Update
Dear Customer,
We are experiencing a service disruption with our Recorded Future application portal, mobile application and API. These services are currently unavailable. Our engineers are working diligently to resolve this issue as quickly as possible.
The issue has been identified, and a fix is being implemented.
Posted Jun 04, 2025 - 06:04 EDT
Update
We are continuing to investigate this issue.
Posted Jun 04, 2025 - 05:49 EDT
Investigating
Dear Customer,
We are currently experiencing a service disruption with the Recorded Future application portal & Mobile Application. Our product operations team are actively working on restoring accessibility to an optimal level of service.
We will continue to provide updates as they become available. Please contact our support team at support@recordedfuture.com if you have any questions.
Regards, Recorded Future Platform Operations
Posted Jun 04, 2025 - 05:38 EDT
This incident affected: User Interface, API, and Mobile application.